We're hiring!

Which BitBoxApp version is required?

In order to connect your BitBox02 with Pocket using the BitBoxApp, you'll need at least version 4.29.0 (August 4th 2021).

You can find your current version in the bottom right when you start your BitBoxApp.

Always download the latest update directly from Shift Crypto.

Still have a question? Do not hesitate to contact us.